3.3 Main Menu Bar

The main menu bar gives you various options to control the overall functioning of LMMS.

3.3.1 File Menu

The file menu allows you to load, save and export projects, import MIDI files and Hydrogen files. You can also save new versions of your song.

File menu
  • New creates a new project

  • Open gives you a dialog to choose an existing project file to open

  • Recently opened projects opens up a sub-menu listing all the recent project files you have opened, so that you can easily open a project you were recently working on. This doeas not include a project that you have just created and saved, so you have to open the project at least once before it will show up in this menu.

  • Save saves the current project if it has already been saved. If not it functions as if you had chosen "Save as". In LMMS, you have two project-options:

    • <myname.MMP> - creates an XML file, that can be read in any text editor. Avoid editors like MS Word, because that will add editor formatting, and will destroy the project!

    • <myname.MMPZ> - creates a coded and compressed file, that cannot be read in any editor. The benefit is that these files occupy significantly smaller disk space.

  • Save as new version saves the current project with an additional number, starting with 01

  • Save As gives you a dialog to choose a (new) location and name to save your project in. You can also choose to save your project as a template. If you want to change the default template, you can save a template called default.mpt and put it in a (new) directory called templates in your project folder. Templates let you make a collection of different "standards". You can have one template for Rock, and another for Trance, and so on. Templates can be cool, but avoid the pitfall of always making all your music in a genre, with the same instruments.

  • Import allows you to import MIDI, FL and Hydrogen files as new instrument and drum lines.

  • Export allows you to export your song as an uncompressed WAV file or compressed OGG file. No MP3 file export support is planned. Once you gave chosen a name and location to save the file, you then get presented with a dialog. On pressing "OK" the song will be performed from where the playback point was last set. To get the entire song exported you should check that the playback mark is at the start of the song before exporting it.

  • Quit exits LMMS. You will be asked if you want to save your project if you have done any work on it since tha last save or since you created it.

3.3.2 Edit Menu

Edit menu

The first two options in this menu are Undo and Redo. These can be also accessed by pressing the common keys Ctrl+Z and Shift+Ctrl+Z, respectively. They allow you to step backward, or forward, through a history of edits to your project, reversing mistaken actions or re-applying them.

The Undo feature only works correctly for some forms of editing. In particular, in the Piano Roll Editor the bulk move, copy and paste facilities using the selection tool and/or clipboard do not get undone or redone correctly. The developers are aware of this problem and are working on a fix in a future version.

The third option is Settings, which opens the Settings dialog.

3.3.3 Tools Menu

Tools menu

The only option currently in this menu is the LADSPA Plugin Browser. It can be used to view information about available LADSPA Plugins, and the alike.

3.3.4 Help Menu

Help menu

There are three items:

  • Help opens the wiki's Main Page

  • What's This? changes your cursor into a help cursor. When you click on any part of a LMMS window, you will then see the contextual help for this item. Much of the help is in place but some items are still awaiting text being written for them.

  • About gives you a dialog which lists the LMMS program version, its home page, its key developers, translation information if you are using LMMS in a language other than English, and the GNU GPL license that the software is released under.